Animation crashes my godot

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By MrHells

So, I’ve been trying to make a 3d character with some animations and got a problem, it starts when I export from blender as .glb (glTF 2.0) and not all animations come with my file.

I figured that I could overcome this but not fix by exporting while in the action, so it will be there, and I could save the .anim to use later (or not)

with all my animations saved on a folder, I could finaly make an AnimationPlayer and an AnimationTree.

The problem comes when I: Open a “new inhereit” of my 3d model with the animations and try clicking on the Skeleton Node, when I close and open my project and can’t select my animation player(because now it’s a fork bomb to my godot) and when I activate my animation tree with the animation player.

The actual error that spams in my cmd is
ERROR: On Animation: ‘Attack_1’, couldn’t resolve track: ‘rig/Skeleton:mchlid_t_l_2’.
At: scene/animation/animation_player.cpp:251 attack is the animation, the track is some of the bones.

Some informations I think that can help is that I am using MonoDevelopment but actually using only gdnative(maybe I will try to change it), I am using rigify on blender and I can’t realize if this error is from blender or godot.

You tried to exporting to other format that supports animations?

Mxt08 | 2021-03-28 19:54

I tried FBX, but I got in other problem with the render, and also tried that .dae, but also could not work with, the problem was actually my 3d model.

I did make another character, this time without using blender’s rigify for animation, and works pretty well.
In fact, to use rigify properly, with unity, you need to export using an especific library because some bones can’t be read(I could see it when my animations looked kinda melty), and I could not find one for godot.

MrHells | 2021-03-29 14:09