"App not installed" error on Android

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By pederbacher


I try to export to Android and have followed the necessary steps described.

It work for one project, but not for another, where I get “App not installed” when trying to install the generated and signed .apk file.

I am on Fedora and have openjdk version “1.8.0_265”.

I took the .apk and signed it from the Andoid app “apk-signer” and then it installed with no problem!

So it must be something with the signing of this particular project, however it works for another project!

I really need some help after trying too many hours debugging…It has worked flawlessly for a long time and I am not sure what happened such that it’s not able to install.

Please, any clues?

Thanks in advance, Peder

i had same error with my Samsung , it’s work fine with USB remote debug , but if i download the apk debug file at my Samsung, this error show up for some reason , anyway i fixed my problem , because play protect was on, it’s a google play store, if it’s on, you can’t install anything , the developer mode was on and install unknown app from my file was allowed, and yet i get this error

Sorano Sakura | 2023-06-06 14:57

:bust_in_silhouette: Reply From: pederbacher

I figured out the problem…

By running Godot from the commandline the following was written out when playing the project directly to an Android device via usb:

adb: failed to install /home/pbac/.cache/godot/tmpexport.apk: Failure [INSTALL_PARSE_FAILED_NO_CERTIFICATES: Failed to collect certificates from /data/app/vmdl748393312.tmp/base.apk: /data/app/vmdl748393312.tmp/base.apk: File assets/assets/fonts/Font_§.ttf in manifest does not exist]

So I think the problem was, that the “§” is not allowed in a filename for the signing to work…somehow!

Works now :slight_smile: