Audio bus is silent, but spectrum analyser says otherwise

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By andersmmg

Pretty much all info is in the title. What could be causing this? Because of it, my game wont work as intended.

Edit: The problem is that the audio is finished playing, as it should be, but the spectrum analyser is still jumping avery few seconds even though there isn’t and shouldn’t be sound playing anymore.

:bust_in_silhouette: Reply From: The_Black_Chess_King

Couple of things you could try:

1 - If the M is red like in the picture below, it means the audio bus it’s muted.
2 - If you have multiple audio buses, and the S is pressed in any of them, it’s in solo mode, and will mute all the other buses.
3 - If you have some effects or chains, the B pressed will bypass any links between buses you previously had.
4 - If you change the settings, or effects, or edit the buses in any way through scripts, post the codes for us to take a look.
5 - See if your audio nodes (audiostreams) are directed to the corrected buses, there’s a bus property in every audiostream, which by default is set to master.
6 - Check if you have sound in your system, hardware-wise.
7 - Check your options in the audio tab for your project.

enter image description here

If anything above doesn’t work, here’s the godot doc for the audio buses: Audio buses — Godot Engine (3.2) documentation in English

I edited the question, I think my description was confusing.

andersmmg | 2020-03-31 14:53

Does your audio is a .ogg file? Currently by default in 3.2 they loop forever, where only .wav files are meant to be played once. You can check your import options in the audiostream resource also for more options.

Maybe you could try to silence any remaining hidden audio output, by switching your audio stream for a completely silent file, other engines did that, it’s simply a short track with no sound, although I never needed to do that, so I don’t know if it will work in your case.

The_Black_Chess_King | 2020-03-31 22:17

It’s a wav file, and it’s not set to loop. I tried setting the stream to null, setting it to an empty wav file, and doing stop() it when the finished signal is fired. It still did the same thing. So weird.

andersmmg | 2020-04-01 13:49

I have the same problem :frowning:
it’s like something is looping. But really nothing is playing. Just the spectrum analyzer keeps giving values!

lateraluser | 2020-07-14 14:45