Audio plays crushed, slower and crackling

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By SotosSW

Hi,

This is a similar issue as question #67239.
I’ve been searching over for a solution with no results. I’m on the most recent version of Godot (4.0.3 mono). Just finished building the 2D demo project.
Apparently all sounds sound like they are ran on the wrong bit rate. They sound crushed, slower and jittery.

I’ve followed tips to change driver and bit rate in the engine. Changed my PC bit rate to match the one in Godot and adjusted latency to test for differences. No matter the adjustments the end result is the same.

Please note that as a sound engineer I use a external USB audio interface which due to the old manufacturing date, no new drivers exist. The interface however works fine in all other applications but the engine so I assume it’s an engine-related matter.

I have a modest programming knowledge so feel free to ask for any additional details I can provide for the issue.

EDIT: Tried changing the audio driver, but the only audio drivers built in Godot 4.0.3 are WASAPI and Dummy.
EDIT2: Tried building version 4.0.3 of the engine with the Xaudio2 driver enabled and the compiler returned an error upon processing the code/header files. I guess it’s not compatible as it’s depreciated.

:bust_in_silhouette: Reply From: jgee_23_

You might want to try to change the audio file’s format, or change the import settings by selecting the file from the FileSystem tab in the editor, go to the Import tab (next to the Scene tab where the scene tree is) and change some settings there.

I remember in Godot v3.x in the editor you could go to the AudioStreamPlayer node, click on the stream property which would take you to a AudioStreamSample object and you could change the format property to 8-bit, 16-bit or IMA-ADPCM. However I cannot find this in Godot v4.1… maybe they moved it somewhere else?

Tried changing the sample rate, fidgeted around with the properties, tried importing it as .ogg, .wav and .mp3. Nothing works. The only noticeable difference was when I set a 44100hz sound bit rate to 48000hz to which the sound played sped-up as expected but still crushed with artifacts.

SotosSW | 2023-07-07 13:53