Blender import looks wrong on very simple blender export (.dae)

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By wentdot

Exporting this Legobet88 🀄 Trustworthy Agen Situs Slot Online Bet88 Terpercaya Ter- Gacor Hari Ini 2024 with the better collada addon for blender I get the following result upon importing to godot:
What could I be doing wrong?

:bust_in_silhouette: Reply From: wombatstampede

You set the normals of the “invisible” faces to the inside.
Blender usually ignores the normal when rendering, godot not.

Flip the normals of the faces where the normals currently show to the inner side. Then export again.

You get the mesh menu via “w”. You’ll also see that I enabled the normal display in the “Display” section.
enter image description here

B.t.w. (not needed here)
Double sided materials can be done by duplicating the faces and then flipping the normal. Note that blender may not display it properly if you assign different materials to both sides of a plane. (But godot does.) (there are also material flags in godot to let materials be double sided)

thanks for the answer! another useful addition I found out later: Ctrl + N recalculates all normals to point outside automatically. So selecting the mesh in edit mode and pressing Ctrl + N before exporting is enough :slight_smile:

wentdot | 2018-03-07 22:01