Boot splash image disappears on android.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By TitanicJoe

I exported my project using Godot 3.3 and then I tried 3.3.4. On Android (in my case 6.0.1) boot splash image appears for a split of seconds and then disappears. There is black screen during loading resources.
What’s interesting using Godot 3.2, there is no such a problem. Splash image is up through all loading process.
Do only I have this issue? Is anyone who know how to fix this?

:bust_in_silhouette: Reply From: deaton64


I think I had this issue, or something like it. When I set mine in the project settings, it was fine. Well I haven’t tried on 3.3.3 or 3.3.4, so I’ll try it and report back :slight_smile:

I do have my file in res://gfx/misc/logo.png, with “Fullsize” & Use Filter" checked.

Had to update my Android SDK and I’m exporting using Windows. I managed to get the same thing as you. However, it’s not consistent.
I had the splash screen once, then not at all after numerous relaunches. Rebooting the phone got the splash screen back for a few launches and then nothing, then back again.
It does seem a bit unpredictable.
I’m testing on Android 8.1.0. It’s an old phone I’m testing on, but I would expect the splash screen to work.
Not an answer to your problem, but you’re not the only one :slight_smile:
Maybe raise it as an issue on Github.

Just tried on Android 10 and it works everytime.