Buttons not reacting to mouse hover (or anything)

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By IdkAustin

I have a 2D scene with any button under it and it will not respond to my mouse at all. I’ve tried all the buttons under button and and also tried a bitmap on the texture button.
enter image description here

:bust_in_silhouette: Reply From: psear

There may be another control node overlapping those buttons. Even if the node itself doesn’t cover the buttons, if the rect covers them they might not pick up the mouse.

can set the Mouse Filter property of the blocking Control to pass or ignore instead of block (default) to let it though

rakkarage | 2020-06-18 15:07

It's not working

Does having it as not the main scene effect it at all? I created a new scene and and trying to instance it into the game. I only have the control node and the button. Still nothing.

img link: Imgur: The magic of the Internet

IdkAustin | 2020-06-19 00:07

1 Like

Mouse filter worked for me