C# suggestions not showing up in VSCode! MacOS

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Mehmet0zen

The Issue:
I’ve learned GDScript enough to create more than a 3D Platformer, but I really like the aesthetic of C#, I normally started with it, that’s why I want to continue using it!
I see that a few youtubers use C# with godot code snippets, Usually my C# snippets was working until the latest C# extension update in VSCode. Now, even if I downgrade the extension, the suggestions does not show up!

What I tried:

  • ReInstalling .Net and locating the path for omnisharp (the extension)
  • Research about the problem and fix it through extension settings.
  • Installing the older versions of both C# and Godot extensions.

What’s expected:

  • Get code suggestions in vscode according to the godot editor currently open.

MacOS Monterey (13-inch, M1, 2020)
VSCode version 1.72

Settings for C# Extension:

 "godot.csharp.executablePath": "/Applications/Godot/Godot 3.5.1.app",
  "omnisharp.organizeImportsOnFormat": true,
  "omnisharp.disableMSBuildDiagnosticWarning": true,
  "omnisharp.enableAsyncCompletion": true,
  "omnisharp.enableDecompilationSupport": true,
  "omnisharp.enableMsBuildLoadProjectsOnDemand": true,
  "omnisharp.dotnetPath": "/Users/{username}/.dotnet",
  "omnisharp.path": "latest",
  "omnisharp.useModernNet": false,
  "color-highlight.languages": [

  "omnisharp.useGlobalMono": "always",
  "redhat.telemetry.enabled": true,

Errors From Omnisharp, the extension:
When loaded at start omnisharp says;

[fail]: OmniSharp.MSBuild.ProjectManager
Attempted to update project that is not loaded: C#.csproj
Received response for /v2/codestructure but could not find request.

Even tho I have a file called C#.csproj

I get to fix C# snippets by changing useModernNet to true!
However it’s still not showing the godot snippets…

For those still struggling in the future:

  1. In VsCode → C# extension → install another version ––> v1.24.4
  2. Uncheck useModernNet to false! You can’t use both mono and .NET framework.
  3. Do a fresh install of **mono ** and set “omnisharp.useGlobalMono”: “always”,
  4. Install Godot Tools extension
  5. restart OmniSharp and VsCode

Damn, I wasted 2 days for this to work.
Happy Coding!

nigthguarder | 2022-11-08 21:54

:bust_in_silhouette: Reply From: Mehmet0zen

Figured out the issue!
Answering my own question instead of deleting it, (in case someone else having trouble with it)

There are lots of other possibilities but what I was missing is that I needed to check Wait for debugger in Godot Project settings!

But as I said, there might be other issues, if you are facing the similar issue and this is not working for you, please comment down below!