Can I change "Pixels Per Unit"of the sprite like Unity?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By dreamfever18

I am new to Godot Engine, and use NinePatchRect to make a dialogue box.
But I encounter the problem is that the corners(the place circled on the image) looks too small.
In Unity, the solution is changing "Pixels Per Unit"of the sprite smaller, I didn’t see any similar option on Godot.
Where can I change “Pixels Per Unit”? , or other ways to solve it?

(It’s the image)

Do you mean the embroidering on the corners look too low-res? If that’s the case, try this:

(I’ll be using the above image to demonstrate)
In the FileSystem (bottom left on the image), select the image you used in your Sprite node. Once you have selected, go to the “Scene” tab (top left on the image). Right next to the “Scene” tab should be the “Import” tab.

Once you are in the Import tab, it should look like the above.

Note the file selected in the “FileSystem” and the “Reimport” button.

Once you are here, you should try fiddling around with the properties. Try to turn “filter” on and off. To apply the changes, press “reimport”. If you turn filter off (and it doesn’t work), turn it on again and turn on “mipmaps”.

(I’m also assuming the image you are working with is a Raster image (.PNG, .JPG), and not a vector image.)

And also a few more things to note from my own experiences:
If your images are low-res, of lower quality, or they are too small, well then you should find yourself a better image.
If your images are vector images (and they are .SVG format), try scaling the vector image in the “SVG” section.
And finally, if your images are too big (so if they are too big, or you scaled them up too much in the SVG section), as soon as you down-scale the big image, it will turn pixelated and weird. If this is the case, turn on ‘filter’ and ‘mipmaps’.

For further reading:
Import process — Godot Engine (stable) documentation in English
Importing images — Godot Engine (stable) documentation in English

TheJokingJack | 2021-08-22 15:37

Thank you for answering my question, Let me describe my problem more detailed.
In short, my box is displayed like A on Godot, but I need it displaying like B.

dreamfever18 | 2021-08-22 16:45

Is the embroidery a sprite? Is it auto-generated?

Edit: I’ve looked again, and it seems as if it’s a sprite. Could you explain to me how your text box is generated?

TheJokingJack | 2021-08-22 20:10

It’s a sprite, and I expand it with NinePatchRect.

dreamfever18 | 2021-08-23 04:55

How about making your sprite texture itself bigger? Your texture looks really small.

Or you could even just upscale the ‘Scale’ property under the ‘Rect’ section. You might have to change a few things, but it will make everything bigger.

Edit: I’m also sorry for overlooking a few things in the original question. Kinda took you into a full circle.

TheJokingJack | 2021-08-24 02:42

OK,It seems like I can’t adjust some options to enlarge the sprite on Godot…, I will enlarge my sprite. Thank you for helping me!

dreamfever18 | 2021-08-24 13:42