Can someone explain what ""det == 0" is true" error means?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Happyman

Hi. I created a tooltip that’s shown when mouse enters the button area. Showing and hiding tooltip works perfect, but when in some cases I hover a mouse over the tooltip the game crashes with error:

“det == 0” is true
at: affine_invert (core/math/transform_2d.cpp: 49)

So everything works great until the mouse gets over the tooltip. Because it doesn’t show any errors in the actual code, I have no idea what’s wrong here.

:bust_in_silhouette: Reply From: Gluon

Do you have a light 2d set up in your project? If so you might want to check if the noise texture has a noise defined. Or remove the light 2d and see if you still get the same error.

No, I don’t have any light in the project. I’ll try to change node types and see what happens.
After all, I’m just interested in figuring out what sort of error is this because it’s not shown in debugger. I see a some people have it for multiple reasons. It’s just confusing.

Happyman | 2022-02-08 10:38

Yeah sorry I have never been able to understand what drives that error but I have seen it on a scene with a light 2d node which wasnt set up properly. It may be that a different node type creates a similar issue if not fully set up but I am not sure I can help beyond that sorry

Gluon | 2022-02-08 10:40

Looks like I’ve found the problem. All nodes in the tooltip tree had to be set to mouse/ignore. Probably there was some conflict there. Now it works nice. In any case, thanks for your time.

Happyman | 2022-02-08 15:03