Can't disable SRGB on a png

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By szabotudor

Exactly like the title says… I go to the Import tab and set srgb for a png image to ‘detect’, however, immediately after switching the scene or running the project, the setting is changed back to ‘enable’.

I’ve noticed that this happens less frequently when the image is not set as a texture on a 3d object, but I first of, it happens anyway, and second I need it both on a mesh and a sprite (as a button icon)

This happens with any png I use (downloaded, or drawn in Krita/Photoshop) in multiple projects and in multiple versions of Godot (I’ve only tested 3 versions though, and pretty close to each other)

Potentially stupid question so forgive me, but are you pressing the reimport button after setting the SRGB property?

timothybrentwood | 2021-05-14 16:16

yes, I am pressing it

szabotudor | 2021-05-14 16:17

:bust_in_silhouette: Reply From: Lopy

I have the same issue other properties as well. Something is writing random values to the .import of the image when I manipulate them.

It seems like the change only happens if the properties are equal to the import default.

A temporary fix is to set your default import settings to what you need, and periodically delete all .imports. You can also manually edit the .imports in a text editor, the format is straightforward.