Can't fully control my Camera node in 3D scene

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By byjove

Hello. I’m trying to learn to use the camera in a 3D scene in Godot, and I was happy to realize it is similar with Unity. But however, neither I can:
**- get a preview of it: I get a full black screen when using it, even when I activate the “Current” property)

  • scaling its view area: see the little point at the center? it stays fixed to this position, even when I try to change it.**

I’m on Arch Linux and Godot is up-to-date. I’d like to know if possible how to correct this problem. Thanks in advance.

A pic of what I got in the scene editor.

Could you give us a few more details? How is the scene setup? Maybe tell us more about the camera in the scene.

Ertain | 2021-08-24 09:05

Well, there’s not a lot do say more… It’s just an average test scene with meshes I imported from a GameCube game so I could test my game mechanics on it. That’s the worst thing: I almost did nothing, but I anyways meet this issue.
Maybe some screens will help you more.

enter image description here
The scene in question.

enter image description here
The camera settings.

There’s nothing else in the scene if not a Sun-type light node, an audio stream player and a WorldEnvironment node.

byjove | 2021-08-25 06:23

stupid question (since i cant see the position of the camera node in the scene) but is the camera actually looking at something that is not a black background?

Andrea | 2021-08-25 12:05

No worries, I’ll reply anyways.
At the first look, I thought the camera was just looking in the void, but even after doing some tests, no matter what direction it’s turned on, the render is still black.
The 2D sprite representing the camera doesn’t help at all since I can’t see its rotation without looking in the settings tab.

byjove | 2021-08-26 14:53

That’s strange, the camera sprite should have a pink square in front of it to represent direction and fov.
You might have changed some settings without noticing. Is it the same if you create a new scene or a while new project?

Andrea | 2021-08-26 17:33

Strangely, when I create a new scene, the camera works flawlessly. It doesn’t when I just create another camera in my game scenes. It’s probably a setting I edited accidentally, but I don’t know what is it.

byjove | 2021-08-26 17:44

A good opportunity to go through all settings and find out what each one does :slight_smile:

Andrea | 2021-08-26 17:47

Well I don’t really think it’s a setting because I don’t find anything related to this in global settings, plus the fact I just need to create another scene to get a working camera, but I can’t just indefinitely create scenes each time the Camera does whatever.

byjove | 2021-08-26 17:55

Welp, didn’t found any settings that could explain this.

byjove | 2021-08-27 07:11

is it posible the transform scale of the camera or parent is (0,0,0)?

Andrea | 2021-08-27 07:57

Just checked, it’s not. Actually, its parent is the scene node so it’s pretty normal it’s located to 0, 0, 0. I just feel like the FOV is blocked to 0 whileas it shouldn’t be, or that render is not happening.

byjove | 2021-08-30 06:57

I’m talking about the scale though, non the transform position
I think FOV minimum value is 1, there is no way to go lower

Andrea | 2021-08-30 06:59

Oops, I misread. Nope, scale is on 1;1;1 and FOV at 70.

byjove | 2021-08-30 12:42

Care to share the project?

Andrea | 2021-08-30 13:02

File on MEGA

I prefer to give you the scene, it’ll be lighter and quicker. When I create a new scene, the problem disappears but I’d like to get the solution so I don’t have to recreate scenes eternally.

byjove | 2021-08-30 13:24

:bust_in_silhouette: Reply From: Andrea

the project on your code has some missing dependencies, BUT it looks like the 3D scene is simply too big.
The camera has a far property, try increase it to it’s max value and you might see something appear

I succeeded to restore the render with the far property but the FOV stays blocked. I still can’t modify it inside the scene editor.

byjove | 2021-08-30 15:44

you mean in the 3D scene editor?
i think that everything is so big and up in the sky that the editor goes a little crazy, and focus on the 3DCamera node from a huge distance, reason why you dont even see the FOV square… it is simply too distant :stuck_out_tongue: try zoom in with the mouse wheel.

also, before going on, i really suggest to scale the entire scene back to normal dimensions, or reimport it already scaled

Andrea | 2021-08-30 16:07

Oh yeah… Just checked, and it seems you’re right. The scene is definitely too big, I wouldn’t expect that… Thanks you for your help!

byjove | 2021-08-30 16:10