Can't run exported project

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By nunya

Hi, I tried running an exported project. In the editor it was working fine, same with exporting, it created an exe file and a pck file as expected. However, the exe file is 0 KB and when I try to run it, I get a “this app can’t run on your pc” message, despite that it worked fine in the editor. I tried exporting a test project that had only one empty node (Node2d) and still got the same message. When I tried to embed the pck file I got a “executable file header is corrupted” by the engine. Any ideas?

I have the exact same situation but my project is a total of 53 MB so the size can’t be the problem. However I get the exact same situation being either an error message when exporting with “embed pck” enabled or an exported but empty .exe file that can’t run and a separate pck file. Any ideas?

Cashew | 2023-04-28 08:37

:bust_in_silhouette: Reply From: Gluon

There is an issue if your game files are too large (around 2.1 Gb) which causes this error. If this is the problem you are facing I am afraid the only answer I know of would be splitting the project out into various .pck files to attach to the main game.

I had this issue, and the solution I found was to export with debug enabled. That was the only way it’d work for me, my game was definitely not 2 GB in size.