CanvasModulate does not work in the animation player (Again)

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By JerryHayat

I already worked with him, but the last time the problem was solved by itself (lol), but I decided to complicate the system, and I have the same problem. I noticed that when the game starts, everything works for a few moments, and then it stops. Perhaps someone knows what errors may be in his work

I can’t show the code, and it makes no sense, everything works on the animation track

I will be very grateful for your help.

One more thing, debug works fine, although spelled out the same way.

	if time1 >= -10:
	$"debug") (This working)
if time1 >= 0: 
	$"0-1") (This not working)
if time1 >= 5: 
	$"5-6") (This not working)

Differences in animation length only LOL

JerryHayat | 2020-06-21 21:24

I can’t show the code

How do you expect anyone to help you when you’re neither willing to share your code nor describe in detail what happens and what you would expect to happen instead? All I got from your post is that you’re somehow using CanvasModulate together with an AnimationPlayer and it “works” for a few moments and then “stops” - whatever that’s supposed to mean without even knowing what you’re trying to do…

njamster | 2020-06-22 11:10