Code Folding not working

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By eod

I can’t seem to enable code folding. Godot 3.2.1.

In the Editor settings it says its enabled. In the shortcut mapping I see it set to Alt+F

When I press that on a line, the code does not fold. FWIW, I don’t see the little “v” symbol to the left of func and similar where I should be able to fold it.

Is there some other setting I should be considering?

:bust_in_silhouette: Reply From: jgodfrey

Looking here, this setting (by itself) activates/deactivates code folding for me (in the 3.2.1 Windows build)

Editor Settings | General | Text Editor | Appearance | Code Folding

So weird. I toggled that option so many times. Even restarted Godot… and it didn’t work. I just tried it again just now after reading your comment and it worked. Ha.

eod | 2020-05-02 21:24


Glad it’s working…

jgodfrey | 2020-05-03 02:34