Compiling the Godot engine, link issue during the final step

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By fpecheux

Dear all,

I recently tried to compile godot 3.4 on a jeston nano installed with the last nvidia image. Unlike my previous successes with older versions of both godot engine and nvidia image, I now get the following error during the final linking process:

platform/x11/ In function main': /home/fpecheux/Applis/godot-3.4-stable/platform/x11/godot_x11.cpp:39:(.text+0x1c): relocation truncated to fit: R_AARCH64_LD64_GOTPAGE_LO15 against symbol __stack_chk_guard@@GLIBC_2.17’ defined in section in /lib/aarch64-linux-gnu/
/home/fpecheux/Applis/godot-3.4-stable/platform/x11/godot_x11.cpp:39: warning: Too many GOT entries for -fpic, please recompile with -fPIC
/usr/bin/ld: final link failed: Nonrepresentable section on output
collect2: error: ld returned 1 exit status
scons: *** [bin/] Error 1

I tried to add the -fPIC flag in SConstruct but whatever I do the error persists.

Does anyone know how to fix this problem, please ?

Thank you