Console not printing output in Godot 3.0

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Diet Estus

Suddenly I can no longer print to the console in Godot 3.0. I can print in a new project, but not my old one.

Even when I delete all files and singletons in my project except for a simple node with a script print("test") in _ready(), I get no output except the normal “Debugger Process Started” message. I don’t even get the normal “OpenGL ES 3.0 Renderer…” message.

I have seen a few questions online about this problem for Godot 2.0, and the answers involve changing the host/port in editor settings (for example, here).

My remote host is listed as with remote port 6007.

How do I fix this?

I’m on MacOS Sierra 10.12.6.

I don’t think this is an overflow issue since I am not trying to print much.

When I start Godot, I click to allow Godot to accept incoming network connections. I also checked that Godot can accept connections from my Privacy Settings.

This may not be related, but when I run my code, I get the following warning:

Remote Debugger: Connection failed with status: ‘2’, retrying in 1 msec.

The debugger seems to be working in that it still kills the run on errors.

I have also reported the problem as a comment on issue 1287, with a bit more info.

:bust_in_silhouette: Reply From: Diet Estus

I solved this myself.

When I consulted the project.godot file in my project folder, I noticed there was a line


This line was disabling the standard output, preventing printing to the console. I changed it to false and everything worked hunky-dory.

You can toggle this setting on and off in Project Settings > Application > Run.

Hm. Got excited, but this wasn’t my issue. Still looking for another reason…

xicus | 2020-09-02 03:55