Does Oculus Quest networking not work?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By stormreaver

I’m experimenting with networking with the Oculus Quest, but it appears to not work. I have a simple StreamPeerTCP example that connects to my remote hosted server just fine when I run it from my desktop, but that doesn’t even connect when run from the Quest.

Does Godot networking not function from the Quest? I’m using an earlier Godot 3.2 Alpha build (24e1039eb), in case that matters. This is the code I’m using:

func connectToServer():
	m_server =

I have the same problem with the latest official release of 3.2.

stormreaver | 2020-01-30 02:35

I think I have narrowed down the problem to a Godot/Android interaction. For some reason, Godot on Android is unable to perform host name resolution. GDScript’s connect_to_host() method returns either error 1 (general error) or error 26 (unable to resolve).

Does anyone have any ideas on why this happens?

stormreaver | 2020-01-31 17:46

:bust_in_silhouette: Reply From: stormreaver

All I needed to do was check the Internet permission on my export, and networking on the Quest and Android worked.