Doubt about lines in Tilemap

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By DarlesLSF

Why appears those “lines” between the tiles?
enter image description here

The size of each tile is 16x16.

:bust_in_silhouette: Reply From: Lyceq

This is mentioned in the Tips & Tricks section in the Godot documentation for TileMaps. Here is the relevant quote.

If you’re using a Camera2D to scroll your level, you may notice lines appearing between your tiles. To fix this, open Project Settings and enable “Use Pixel Snap” in the “Rendering/Quality” section.

Here is an image that might help you find it.
Use Pixel Snap

:bust_in_silhouette: Reply From: MaggoFFM

In Project Settings → Rendering → Quality. Turn “Use Pixel Snap” on.

I am not 100% sure but i had a similiar issue long time ago and this helped.

:bust_in_silhouette: Reply From: scrubswithnosleeves

Just for future people with this problem. try Importing without the filter on. my “lines” were really just a little bleed from the adjacent tiles because of the filter. I didn’t event need the “use pixel snap”. BTW, the “use pixel snap” setting is now in Project Settings > Quality > 2D > Snapping and is called Use GPU Pixel Snap