Dualshock dpad input not working correctly

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By SrVerde

The dpad of the dualshock stops the player while im pressing it, I have to press it again to keep moving the player.

Godot seems to detect that im releasing the dpad button when im not. Also if I run the project using keyboard there is no problem, but if I change to dpad(not working), and I go again with keyboard, its kind of like the bug infects the keyboard too and starts to stop the player again even when it worked at the beginning. Once I disconnect the ds4 the keyboard instantly works again.

I dont think is the movement script because it works perfectly on keyboard, xbox dpad, even the ds4 joystick works as expected. This only happens with the ds4 dpad.

Id like to know how to fix it.

:bust_in_silhouette: Reply From: citadel

I am having the exact same problem. I am running Linux and for some reason this is happening. This never happened before. I am surprised nobody else has answered this post. Maybe making an issue report on GitHub will be more fruitful in getting help. I’ll go ahead and do this. Oddly enough, I am using Godot 3.5.1 stable.