Editor "custom build"

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By EnrikeChurin

I’ve been using Godot editor on arm Linux machine. It was build in my distribution’s repository. And because (I think) arm Linux isn’t officially supported, the version was .stable.custom_build . It works all correct on my arm Linux machine. But it’s little outdated (v. 3.2). So I tried to build the newer version of Godot (3.3) as written in documentation. But it failed in the end, on linking step.
So I think I have to do something to make it compile for arm, just like it was done for pacman repository. But I can’t figure out what to do. (Google searches all seem to be about export templates)

:bust_in_silhouette: Reply From: Wakatta

Many things can go wrong with Toolchain builds

  • Is it a fresh build?
  • Do you have all the 3rd party libraries to link to?
  • Are your /sysroot dirs set up correctly?

As your lawyer have to say an error read out of your problem will greatly help your case.
Also Google is your best friend when you know what to ask, try Godot Experimental Build , Godot Toolchain build, Godot arm builds

Forgot one Godot cross platform build

Wakatta | 2021-08-23 15:39

Sorry didn’t copy error code
But I’m doing the build again (on my arm device it take more than an hour)

  • Yes, it’s a fresh build. I got cloned the source and ran scons
  • I’ve installed all libraries Godot depends on. Like it’s said in docs. (Using Linux one-liner)
  • What’s sysroot, (googled rn), no I didn’t setup any systems or roots, just ran scons -j4 platform=x11 target=release_debug in Godot’s source directory.

EnrikeChurin | 2021-08-23 15:59

You’re building on the arm device it self? well don’t you like self torture if it fails again that error please.

Not sure if it’s related but have look at this

Wakatta | 2021-08-23 22:37

Yes, on the device itself. Here is the output. IMG_1336.jpeg - Google Drive
It’s all from the build (next goes me trying to copy text from terminal, ^C)

EnrikeChurin | 2021-08-23 22:50

It would be great if you find the solution, but don’t try to find the solution if it’s not going. I’m fine using 3.2, the features are so minor that my basic projects don’t suffer from not having them

EnrikeChurin | 2021-08-23 22:54

No no, when you get this built, would like to have a copy to test

Wakatta | 2021-08-24 10:40

Didn’t understand you fully, what do you mean? To share the build if I get it working?

EnrikeChurin | 2021-08-24 10:45

Not "if" “when” because we’re gonna get this built buddy
Meant If you can host it on your Google drive like you did the picture and share the link as I have an arm device and would like to test it, but not able to compile like you are.

All that said your issue seems to be a complicated one, have a lot of ideas here and trying to sort out the correct one.

Honestly that function in the os_x11.cpp file does not look that important and would just void it to null (x11 has to do with window management)

Also thinking it could be a change in the linker
Or the order in which the libraries are linked

Hmm… ok first try building without multiple cores

scons platform=x11 target=release_debug

Should not take long with everything already built then if it still fails try as it says adding the -fPIC flag instead of fpic

Wakatta | 2021-08-24 14:05

Ok, doing it right now.
If I get this working I can and will release it on itch.io or put on Google Drive, don’t worry.

EnrikeChurin | 2021-08-24 14:34

It looks like build data doesn’t get saved if the build fails…
Building all over again. I’ll reply when it’s done

EnrikeChurin | 2021-08-24 14:44

The Culprit

Personally tried building using termux apart from being ridiculously slow it fails same way

Wakatta | 2021-11-12 11:00