Emission shader doesn't cast light

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Huday.object

I’m having an issue where this cube with an emission shader does not emit light onto the meshes around it. I did some research and all I could find is that you need to turn on “Use in baked lighting” for the objects you want light to be casted on and I did that as you can see on the right side of the screenshot but it still doesn’t do anything.

Is glow enabled in your environment?

davidoc | 2020-05-08 14:58

:bust_in_silhouette: Reply From: Tim Martin

I think you need to surround the whole area with a GI probe and hit Bake GI Probe at the top of the UI.


Lighting Issue 2 - Album on Imgur
Ok I did that and it seemed to work somewhat but the light doesn’t seem to travel too far.

Huday.object | 2020-05-08 21:25

Hello Huday.object,

Here, you could increase the Emission Energy of the Shader Material.

You could also increase the Propagation parameter of the GI Probe to be closer to 1.0

One/both of those should hopefully give you the effect you’re after.

Tim Martin | 2020-05-08 21:48

Imgur: The magic of the Internet
I tried maxing both values but it only made a small difference

Huday.object | 2020-05-08 22:33

You can manually enter a number larger than the maximum that the slider suggests, but you might find that you start to cause visual problems for yourself elsewhere if you go too large. So you might be better off in the end adding an actual light node up here, to work along side the emissive texture.

Tim Martin | 2020-05-09 11:00