"ERROR: Could not load frame resource!" while creating an animation

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Leandro

Greetings, I’m programming a game and added a scene for a standard explosion animation. One of its nodes is an Animated Sprite. I worked with that at home, and to send it quicker to my office to tweak it a little more, I decided not to send all my game files, just the scenes I changed and the explosion animated image sequence I made, and here at the office I just replaced the scenes I changed.

Weird enough, when I try to run it, Godot cannot find the explosion animation. If I try to remove the Animated Sprite node, create a new “default” animation and load the image sequence files for the explosion, it simply says: “ERROR: Could not load frame resource!” (these image files show a small cube icon in the Godot file browser).

Since my files are all working fine (and they did work at home), what did I miss when I tried to use my files at the office, and how can I fix this?

Thanks in advance!

:bust_in_silhouette: Reply From: Ertain

When you moved only a smaller number of your files, did you ensure that the explosion file wasn’t corrupted? And the *.import files were properly generated?

The Explosion file were working. The Import files, I have no idea of what are they used for.

I created a workaround. I noticed one subfolder was not being shown at the file system, so I created a new subfolder, copied inside there all the original folder content, and deleted the original. After that, I just renamed the new folder as the same name of the original, and Godot rescanned it.

Anyway, I’d still love to understand what happened and why does Godot needs this ton of import files and how do they work.

Leandro | 2018-12-07 19:18

According to the official documentation, the .import files contain the import configuration.

Ertain | 2018-12-07 21:43

:bust_in_silhouette: Reply From: Elendir

I’ve been struggling with pretty much the same problem. Suddenly the image I was using for my Sprite changed into a different icon. Later I figured out that it has actually gone missing completely from my file system.

So If you see the image within the Filesystem dock window in Godot in the following way (the top png file is showing a small thumbnail of the real image and the bottom one only a reference to a nonexistent image):

then open the folder containing that image (I mean not in Godot but in your operating system). This icon indicates that the file is missing. Only its name/reference is shown in the Filesystem dock window in Godot.

In my case it happened like that:

  1. I had a Sprite and an image assigned to it.
  2. I deleted the Sprite Node. This operation has also deleted the image, but the reference to the image remains in my Assets folder in Godot.

A quick fix is just to open the filesystem and see if the image is really there.