Error uploading APK to Google Play

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By feor


Hey guys,

I’m getting this error while trying to upload my signed release APK to Google Play:

Upload failed
You uploaded an APK with an invalid signature (learn more about signing). Error from apksigner: ERROR: JAR_SIG_NO_MANIFEST: Missing META-INF/MANIFEST.MF

Google isn’t being very helpful so I’m turning to you. I’m using Godot 2.1.4 compiled from windows for windows because of a custom module I’m using, so I compile my own release export template for android using JDK 8, NDK 13b, and I’ve tried switching through many different versions of the SDK though for some reason when I run ‘gradlew build’ it always tries to revert to build-tools 26 even if I have other versions installed.

Really not sure where to even begin with this, any help is appreciated.


Solved, I ended up re-signing and re-aligning the .apk generated by godot with the apksigner utility.

GUI available here: Android APK Signing Tool (APK Signer) – Shatter-Box

feor | 2018-04-01 17:49

:bust_in_silhouette: Reply From: Saluki


Could you please send me some more information on how you resolved this? I’m experiencing the same issue, but find your solution a bit too vague. (I’m not sure if you mean create a new keystone, or try and edit the current one - and am not sure how to realign the .all)