Error while trying to create a VSCode solution to debug the engine's source code

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By gonzalezharry

Hi! I wanted to edit the source code of the engine because of a problem I encountered while binding a nodepath argument to a signal via the editor. Since the path returned is always relative to the node emiting the signal, when you connect it to a parent node, it gets unexpected behavior.

The case is, while creating the vs code solution. I see this in my command prompt:

It says "TypeError: ‘NoneType’ object is not iterable

I’ve extracted the again, tried running it in the new folder, tried compiling it normally (it worked) but I’m unable to create the vscode solution.

Any comment on this would be greatly appreciated! :slight_smile:

:bust_in_silhouette: Reply From: PathogenDavid

For me this was being caused by a combination of using Visual Studio 2022 Preview and SCons 4.5.1. If you use non-preview Visual Studio you’ll get a different error instead (see Issues · godotengine/godot · GitHub)

The fix was to uninstall SCons and reinstall using pip install SCons==4.4.0