export error on linux executable

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By dancaer69

I’ve made a project with godot 3.2.3 before some months and I exported it as linux runnable file. That worked every time without errors(with or without pak) file on 3.2.3. I also did it with 2-3 other projects without problems. I’ve switched to 3.3 when was released and I didn’t use export for linux until now. I edited that project before 2 weeks and export it to android. I tried now to exported it to linux but no matter which options I use(empeded pck, runnable or not), when I try to run the binary file I get the error:

ERROR: try_open_pack: Pack created with a newer version of the engine: 3.3.
At: core/io/file_access_pack.cpp:181.
Error: Couldn’t load project data at path “.”. Is the .pck file missing?
If you’ve renamed the executable, the associated .pck file should also be renamed to match the executable’s name (without the extension).

I tried also another project with same result. Do I miss something or is 3.3version bug?

Did you leave an older version of the exported project (binary + PCK file) around? Make sure to remove it, then export again in a different directory. I recommend exporting outside the project directory itself.

Since Godot 3.0, export templates are versioned so the editor no longer allows you to use mismatched export templates… unless you specified a custom export template in one of your export presets.

Calinou | 2021-05-18 16:44

Yes, I had and replaced it, but I tried to remove it. But on the second project I tested I didn’t have exported it never before and I had the same error. I also tried to remove and re-add the Linux-x11 runnable template, but still get the error. The only thing I didn’t tried yet is to export on a different directory. I don’t export to the project’s directory. I have a separate directory in which I export the projects.
just tried to export in a new directory and still have the same error.

dancaer69 | 2021-05-18 17:08

:bust_in_silhouette: Reply From: dancaer69

Seems that I had the previous template version. I thought that remove and re-add the template from editor was enough. I deleted the linux templates and then, after I downloaded them again from editor the exported files were fine.
Thank you.