Exported project does not change scenes after changing project directory

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By pikmeir
:warning: Old Version Published before Godot 3 was released.

I developed a game on one desktop - Windows 8.1 64bit. I’ve made several exports and tested it loads of times. It works fine, and has worked since starting.

I wanted to export on my 2nd desktop - Windows 10 64bit.

Both computers run Godot through Steam.

So I opened the project file on the 2nd desktop. Project opens. Tested it. Runs fine. Everything works fine. Great. “Export” using the settings I’ve already used countless times on my 1st desktop.

The newly made export game opens, the main menu scene plays fine, but as soon as you click to start the game (change scenes) the game freezes and becomes unresponsive (but the music keeps playing).

I can run the original exported file made from my 1st computer, using my 2nd computer and it works perfectly. However, I am unable to export with my 2nd computer.

In fact, after even opening the file on my 2nd desktop, I am now no longer able to export the project even using my 1st desktop. It’s like opening it on the 2nd desktop somehow messed up the export, although I did no changes to the project or to any files whatsoever.

I should note that I moved the project directory before doing this. But even if I copy the project to another drive and try to open it, the exact same issue occurs when trying to export.

edit: I’ve run a debug, and the game gives a lot of these error messages:

edit 2: I also already tried turning on export for all files in project directory, and that didn’t fix it. Although I don’t have any other files in the directory besides Godot files and sprites that Godot loaded itself.

It’s failing to load a bunch of stuff. Double check if they are in fact located in these directories. Check also their extentions. If everything is right, then try to delete export.cfg. If it’s still wrong, download the export templates again, and even Godot. If that also doesn’t help, try the most recent version of Godot here:

mateusak | 2017-01-03 04:55

Keep also a eye on the case sensitive. Better to name all your files with lower case and underscore to avoid some problems

Nutr1z | 2017-01-03 13:54

The files are named the correct way.

pikmeir | 2017-01-03 17:54