Exporting a tutorial project makes an empty .exe file

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Ilya Fedorinov


I’m trying to export the “step-by-step tutorial game”, and Godot produces two files - non-empty .pck, and empty .exe (zero size file).

I tried to reinstall export templates, nothing happened. The archive with project is here: Dodge Creeps.zip - Google Drive

By the way, the “console” for Godot Editor is filled with some kind of errors: https://media.discordapp.net/attachments/342056330523049988/423005154133147648/unknown.png . I don’t know if it is relevant to the problem or not.

Please, help me!..

What is the “step-by-step” tutorial? Is it for a C# game? If so, then what could be happening is that the editor isn’t exporting it, because it looks like you’re running the “NoMono” (i.e. the non-C# version) of the editor.

Ertain | 2018-03-14 07:06

No, I did not use any of C# code in the project. That’s why it is NoMono =-)

Ilya Fedorinov | 2018-03-14 07:59

I’m using the provided project, and I can’t seem to replicate the problem in the Windows build of the engine. Which version of the engine are you using? I’m using version 3.0.2. Are you using the default settings for exporting on Windows? Also, I have none of the errors you have encountered while running the engine.

Ertain | 2018-03-14 21:06

Yes, I am using 3.0.2.stable.official too. I use default settings for export for Windows Desktop.

I’m fucking stuck. I tried to export an empty project and a project which has only one ColoredRect - neither produced non-zero executable.

Ilya Fedorinov | 2018-03-15 04:51

I made this work by deleting an AppData\Godot directory!!! dances Kozachok while drinking mineral water from a vodka bottle

Ilya Fedorinov | 2018-03-15 05:02

I am glad for you, comrade.

Ertain | 2018-03-15 07:06

Thank you! =-))

Ilya Fedorinov | 2018-03-15 11:05

definitely an original celebration. =)

Millard | 2020-11-21 05:00

:bust_in_silhouette: Reply From: dr-pop

Hi Ilya,
I have the same problem. Do you remember which AppData/Godot folder you deleted? Thanks!

You can remove the Godot folder located under %APPDATA% entirely, as it doesn’t contain your project data itself. It only contains export templates, editor settings and persistent data written by projects (such as files saved into user://).

Calinou | 2020-11-27 12:34

Thanks! That didn’t fix it for me unfortunately, but I got it to work by reinstalling the export templates inside the editor.

dr-pop | 2020-11-27 13:52

Hey, i have the exactly same problem, but delete the godot appdata folder didn’t worked, and reinstall the exporting templates didn’t worked too. Someone here have any idea?

SGITW | 2020-12-02 02:31