Exporting for Android trying to use path which no longer exists

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By kitfox

I’m running into trouble trying to export a project for Android. For some reason Godot keeps looking for Java in a location of an old JDK install from years ago which has since been deleted. I’ve updated my JAVA_HOME, reinstalled Java and Android Studio, double checked that the right packages are installed for Android Studio, but nothing helps. Godot refuses to acknowledge my updated JDK path.

I’ve already started discussing this in this thread:

I just tried again - I created a new project that contains one scene with a button and tried to build an AAB with it. I get the error

FAILURE: Build failed with an exception.

* What went wrong:
The supplied javaHome seems to be invalid. I cannot find the java executable. Tried location: C:\Program Files\Java\jdk1.8.0_151\bin\java.exe

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

Exit Code: 1

This is not what JAVA_HOME is

C:\Users\kitfox\.android>echo %JAVA_HOME%
C:\Program Files\Eclipse Adoptium\jdk-

I’m really not sure how to fix this. I was able to export for Android about two years ago, but nothing works after my latest round of upgrades.

My only guess is that something was messed up in your Windows registry.

Ertain | 2022-06-24 23:29

I just searched the registry and there’s nothing relevant with the string ‘jdk’ in it.

kitfox | 2022-06-25 00:27

:bust_in_silhouette: Reply From: kitfox

So it seems Gradle keeps its own registry. There was a file called ./gradle/daemon/7.2/registry.bin in my user directory that was caching the invalid jdk path and once I deleted it I was able to build.

thank you so much.
saved my day.

sanket | 2023-01-07 14:15

1 Like