Failed to access to asset library

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By flim

I am behind a corporate firewall, I got error when I access to Templates, I think that is because I need to add the firewall cert. to the application.

thirdparty/mbedtls/library/ssl_tls.c:5865: x509_verify_cert() returned -9984 (-0x2700)
ERROR: _do_handshake: TLS handshake error: -9984
At: modules/mbedtls/stream_peer_mbedtls.cpp:86
mbedtls error: returned -0x2700

The editor shows “Can’t connect to host:

How to install a cert to the editor, or how to disable TLS?

Godot does not support HTTP(S) proxies yet, so you have to use the web interface instead: Godot Asset Library

The web interface provides the same features as the editor/project manager integration.

Calinou | 2021-10-04 13:47

:bust_in_silhouette: Reply From: Lopy

If you create a dummy project, you can access the editor settings. You should be able to add under Asset Library, Available Urls.
Since the protocol in the url is http instead of https, the connection will not be secured using TLS. However, this also means that someone attacking your company, or Godot users in general, could send you an infected file.

Instead of disabling TLS, you should browse templates and download them using your browser, at

:bust_in_silhouette: Reply From: jabcross

I just had this problem, so commenting the solution here.

This was worked around in commit Asset library doesn't load when using a dual stack IPv4/IPv6 network · Issue #36418 · godotengine/godot · GitHub,
but as of 3.3.4 stable it hasn’t been merged yet.

I managed to work arount it by setting up a IPV6 DNS on my computer, as apparently the one provided my my ISP wasn’t working.