Failed to Build Project Solution

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Red Fox Studios

Hey, everyone.

I began working on a project in Godot 3.2 (the latest stable version). Everything seemed fine until I began scripting my Player; I planned on making a short game using C#, as I have a decent background in it. However, as I tried running ‘Level1.tscn’, I ran into an error stating, “Failed to build project solution”. I run a Windows 10 64-bit operating system with Mono version 5.4.1. I also use MSBuild (Mono). Does anyone have any ideas as to why this is happening? I’ve looked at other posts (even on Reddit) and found nothing that works for me.

Thanks in advance.

Hey there.
I’v had similar issue.
My solution was to install correct version of MSBuild components.

Installed mine from microsoft site. (fist link in google for: “microsoft msbuild download” )

Make sure you checked .Net Framework 4-4.6 version.
It’s not selected by default. Other didn’t work for me.

Also GDQUest’s video was super helpfull.

255h | 2020-02-26 08:03