Flat 2D Texture on MeshInstance not working as advertised

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Felan


I am currently trying to get a square 2D Texture displayed on my MeshInstance Cube. I did the old 3, 2, 1 Trick as described in the godot documentation but so far the texture only shows on one face instead of all of them (Towards positive Z if that makes any difference).

Can anybody help me solve this mystery?

:bust_in_silhouette: Reply From: Felan

Okay, just ran in the issue again.

Turned out enabling “Repeat” in the Sprites import settings was neccessary.

Hope this helps someone else in the future.