Frame rate with Godot 2.1.4 is limited to 40 FPS ?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By securas
:warning: Old Version Published before Godot 3 was released.

For some reason, the frame rate in any of my Godot 2.1.4 projects seems to be capped at 40 FPS. Even a nearly empty scene will run only at 40 FPS.

Is there any specific setting to improve this? I tried turning vsync on and off and fiddled with the physics and application settings with no success…

Did you accidentally set fixed_fps to 40?

wombatTurkey | 2017-10-22 09:06

nope. Physics settings have fsp at 60 but thanks for the suggestion.

securas | 2017-10-22 09:23

Try disabling vsync and see what happens.

eons | 2017-10-22 16:07

Thanks for the suggestion. I tried it without change… I’m starting to wander if it might be something from my system. But it’s a pretty decent laptop with a good processor and GPU.

securas | 2017-10-22 17:20

Is your animation very memory intensive? Are you using set_fixed_process(delta)?

davidpgil | 2017-10-23 18:31