Fullscreen messes with fonts

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By GarlicPerson


When i set the window of my project to fullscreen by any means my fonts get distorted. However when i set the window to resizable and drag the border like a madman to resize the window either to enlarge or shrink it, my fonts stay perfect without any trouble. Even exported an executable to see if its only an editor thing but not.

Any help is welcome! Thanks in advance!

Stretch mode: 2d
Aspect: Keep
Allow Hidpi: on

Win10, Godot 3.2.3.stable

enter image description here

I don’t seem to have a problem with fonts when Fullscreen is enabled. Can you upload a minimal project demonstrating the problem?

Bubu | 2021-04-15 23:26

Sure… but i’m a total noob when it comes to foruming :S how do i upload it? Here or google drive and link?

GarlicPerson | 2021-04-16 07:21

You can use Google Drive and include a link. Make sure that it’s public so that everyone can have access to it.

Bubu | 2021-04-16 09:48

my 2 cents: it seems like the problem is that the letters are randomly moved up and down, and they are cut because they shouldn’t be there anyways.
you could try using a different font, and see if that has the same problem, that would help in identifying if your setup or the font doesn’t play well

1234ab | 2021-04-16 13:10


Sure here you go! Thanks

GarlicPerson | 2021-04-16 14:12


I tried it with other fonts and it has the same effect :s

GarlicPerson | 2021-04-16 14:13

I’ll test this and try to figure out what the problem is.

Bubu | 2021-04-16 14:15

Your link doesn’t seem to work. I cannot download the file.

Bubu | 2021-04-16 14:20

How come? I set the file so that anyone with the link should access it.

GarlicPerson | 2021-04-16 15:01

I can access it but I cannot download it.

Bubu | 2021-04-16 15:02

Try now perhaps? Set it to edit mode.

GarlicPerson | 2021-04-16 15:05

Now it’s working.

Bubu | 2021-04-16 15:10

It’s perfectly fine on my machine. Maybe it’s a graphics driver issue. What is your GPU and driver version?

As a random suggestion, try using the GLES2 backend.

Bubu | 2021-04-16 15:14

yeah probably if the same problem happens with a different font, then probably it’s something off with your setup, trying GLES2 seems to be a good suggestion (just for testing)
and did you try it with BitmapFont (the builtin font e.g.) and DynamicFont (it’s from a file that has the .ttf extension if I’m not wrong) too?
actually, thats a good question if the builtin font is bad too?
another test would be to try it with Label, if it is the same (probably it is but it’s worth trying I think)
and also _draw’s draw_string like this (works on a Node2D and Control too):

func _draw():
	var font: Font = get_font("font", "Label")
	draw_string(font, Vector2(5, 5), "test tEXt is it AlSO bad? lllllllllllllllllllllllll")

1234ab | 2021-04-16 16:07

Okey, so if i try it in another project with default font it does not do this, however if i remove the font from this project then the default font behaves the same way. It’s probably some messup with my setup or idk.

btw i don’t have a top-notch setup [sadface] GPU is a gtx950m (the “m” stands for mom destroyer) with the latest driver.

GarlicPerson | 2021-04-16 16:38

Scratch that i missed it, the other project / a new one does the same as well. I just did not noticed because my eyes are tired. But on second look it does the same, just not so spectacularly, top/bottom of the characters are cut off. Tried GLES2.0 as well. No change.

GarlicPerson | 2021-04-16 16:43

yeah thats probably driver playing not well with Godot then? maybe worth opening a Github issue or maybe try it with the Godot 3.3 release candidate (8 iirc) first?

1234ab | 2021-04-16 16:47

I’ll try!
Thanks for the help bros!

Cheers and stay safe out there!

GarlicPerson | 2021-04-16 16:51

I have a GTX 1050 Ti (Titanium) and the project works fine, so I don’t think that your graphics card is the problem. GTX 950 M is not a very old GPU, so maybe it’s a bug.

Bubu | 2021-04-16 16:52

I think the latest Godot Version is 3.3 rc9.

Bubu | 2021-04-16 16:56