GLES2 Rendering artifacts android

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By zeball

I’m using a pixel 1 phone and whenever a mesh instance gets close to the camera I get really dark shading spots, no clue why. On PC it’s entirely normal


On the pixel

can u send me apk, ur game looks cool

supper_raptor | 2020-05-06 17:11

Vertex shading is forced by default on mobile for performance reasons. Can you reproduce this on PC if you enable Force Vertex Shading in the Project Settings?

Calinou | 2020-05-11 09:40

I’ll give it a go,

Ok. So with force enable vertex shading for PC it still happens.
I played around with disabling all the quality restrictions (enable/disable) for the phone settings before posting too and it still had the artifacts.

zeball | 2020-05-13 01:14

Did you ever solve this? I am having the same issue on latest Godot 3.2.3 (Android, GLES 2). It seems to be related to WorldEnvironment with Sky. Whatever texture I use I get those artifacts. If I change the WorldEnvironment to be Color only, this doesn’t happen. @Calinou, any idea what’s going on? (This does not happens on PC or iOS)

Filippopotamus | 2020-11-13 21:00