gltf model imported without it's animations

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By DriftWare.exe

I have a little guy with a bunch of prepackaged animations in the .glTF model. I can see these animations in the Windows 3d Viewer, but when I import the model and add an animation player, no said animations appear.

:bust_in_silhouette: Reply From: Inces

You have to “Push Down” the animations into NLA editor when in Blender.

Could you elaborate? Are the source files required?

DriftWare.exe | 2022-08-01 19:49

.blend file is required.
You need to open it, go to the ActionEditor tab or usual Animation tab, and for every animation there You need to click an option called “Push Down” - small button near the title of animation/action. It sends animation to NonLinearAnimation Editor (NLA), which is also accessible as a separate Tab, but You don’t need to open it or do anything there. Just push all of the animations down. When it is done, only then can animations be exported into .gltf.

Inces | 2022-08-01 20:12

I have little experience with blender. When I select an animation track, the Push Down button is greyed out.

DriftWare.exe | 2022-08-01 20:25

Ok, maybe it was only doable in ActionEditor.
To the far left of the animation panel, there is a small menu button. Click it, it will expand into lot of view options. Find ActionEditor there. When You choose it You will notice slight change of animation panel. In the middle You will be able to choose whole animations with names, and PushDown will become available for each of them.

Inces | 2022-08-01 20:39

I think i’m already in action editor.

DriftWare.exe | 2022-08-01 20:45

oh wait no.
Didnt have an animation selected for some reason

DriftWare.exe | 2022-08-01 20:46

It works now that I put it into a new inherited scene. Thanks.

DriftWare.exe | 2022-08-01 20:53