Godot 3.5 crashes when opening or running a project

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By ZapticTomato

Hi, so until like 2 days ago everything was running fine with Godot and I dont recall changing anything drastic, but now whenever I open a project the loading screen appears for a cupple of seconds and then the engine crashes.
In the CMD it shows this:

ERROR: Condition “res != ((HRESULT)0x00000000)” is true. Returned: String()
at: get_system_dir (platform/windows/os_windows.cpp:3677)
ERROR: Condition “res != ((HRESULT)0x00000000)” is true. Returned: String()
at: get_system_dir (platform/windows/os_windows.cpp:3677)
WARNING: Case mismatch opening requested file ‘icon.png’, stored as ‘icon.PNG’ in the filesystem. This file will not open when exported to other case-sensitive platforms.
at: _open (drivers/windows/file_access_windows.cpp:102)

Thank you in advance if anybody knows a solution to this :slight_smile:

:bust_in_silhouette: Reply From: Gluon

Well it is telling you it has a problem as it seems the icon in the folder has been renamed too icon.PNG rather than its original value of icon.png. Have you tried going into the file and renaming the icon to have a lowercase file extension to see if this resolves it?

Sry, I forgot to say that the warning-part isnt the problem (that was just smth in one of my projects). I fixed that rly quick, but the main issue thats actually crashing the engine with any project are the two errors above…

ZapticTomato | 2022-11-26 07:31

Are you using godot through steam then? The error messages suggest it cannot access download folders. I dont use it on steam so its download folder is just on my computer but if you are using it through steam and you closed your computer while the program was still running it might cause this issue. If so try verifying the files through steam.

Gluon | 2022-11-26 08:38

No I installed it from the Godot-Website…
And sry if this is a dumb question but what download-folders are you referring to?

Note: Its interesting, when I open a project in Godot4beta instead I get a similar error but the project runs fine and doesnt crash, so maybe it is smth else?

ZapticTomato | 2022-11-26 09:08

I would suggest try re-installing godot then. The error message is a write dump failure which normally means it is trying to reach a location it cannot find for a dump of data. On the steam version of godot this has been seen when the system corrupts after it is closed down incorrectly, it sounds as if you have had a similar issue. Try uninstalling godot and reinstalling. You can copy all of your game files to another location for safety while doing this although you should just be able to link a new project to your old project folder when you reinstall godot but its better to be safe than sorry.

Gluon | 2022-11-26 10:20

Actually that seems to have fixed it…
Dont ask why I havent tried that earlier :slight_smile:

ZapticTomato | 2022-11-26 11:29