Godot 4.0.2: Exporting to Android doesn't show the 3D objects, only the UI

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By xrbtrx


I’m trying to run a simple 3D scene using Godot 4.0.2 with Mobile renderer. I’m able to export and run it on my Android device, however, only the UI that appears on the screen. The rest; a sphere, lighting, and a sky, are nothing but dark grey.

I made another attempt using Compatibility renderer, but no avail. Checked the remote debug, it runs just fine without errors. On another note, I’ve tried the simple 2D example from instancing page, it works just fine, though the initial loading time is slow (takes a few seconds to load after the splash disappear). I got a little more curious, so I tried the simple 3D scene on Godot 3.5.2 LTS with GL 3.0 renderer, it hangs. Tried the GL 2.0 and it works perfectly. Initial loading time is fast too (around a second) compare any of the attempt above, by a few seconds.

The scene contains a Control/Label with text “Hello World”, Camera3D, DirectionalLight3D, WorldEnvironment, and a sphere. The sphere is imported from Blender (as a UV sphere) in .glb format and is saved into Godot’s scene, as sphere.tscn.

My Android device is Samsung Galaxy A03s (Samsung SM-A037F, PowerVR Rogue GE8320). What appears in Godot log is only: “Vulkan API 1.1.131 - Forward Mobile - Using Vulkan Device #0: ImgTec - PowerVR Rogue GE8320”.

Anyone got the same issue? I’m still looking for a solution to this.

:bust_in_silhouette: Reply From: ibrahim.semab

It sounds like the issue may be related to graphics rendering on your device. Mobile devices can have different GPU capabilities and requirements for rendering graphics, and it’s possible that your device’s GPU may not be fully compatible with Godot’s mobile renderer.

Here are a few things you can try to address the issue:

  1. Check the requirements and compatibility of your device’s GPU with
    Godot’s mobile renderer. You can check the Vulkan API version
    supported by your device’s GPU and compare it with the minimum
    requirements for Godot’s mobile renderer.

  2. Try disabling features in the mobile renderer that may be causing
    issues with your device’s GPU. For example, you can try disabling
    certain post-processing effects or lowering the texture quality.

  3. Try using a different renderer in Godot, such as GLES 2.0 or 3.0, to
    see if the issue persists. If it does not, then the issue may be
    specific to the mobile renderer.

  4. Check if there are any driver updates available for your device’s
    GPU, as updated drivers may improve compatibility with Godot’s
    mobile renderer.

  5. Consider simplifying your scene or reducing the number of polygons
    in your models, as this may improve performance on your device’s

Hopefully one of these suggestions helps resolve the issue. Good luck!

Thanks for the hints, I’ll take a look into it further.

xrbtrx | 2023-05-02 07:06

:bust_in_silhouette: Reply From: xrbtrx

I’ve looked through the GitHub issues and found the exact same issue related to the GPU, PowerVR Rogue GE8320. Apparently the issue is still open, so I guess I have to wait for that. Link can be found here.