Godot 4.0 for Mac OS keeps crashing

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Georgios Tsolakidis

So, I downloaded the Godot source code from GitHub and later compiled it for x86 system, just like the documentation on the official site said. I opened the new executable file (godot.osx.tools.x86_64) with the Mac terminal and then had in front of me appear the usual Godot editor.

The engine seemed to work fine at first glance, until I tried making a 2d root node and adding to it the provided “icon.png”. The engine just crashed right there.

Later, I tried to make an .app version of the “godot.osx.tools.x86_64” executable (as instructed in the documentation by Godot.org), however it did not run, saying “Unable to initialise Video driver”, even though I had Vulkan SDK working on my Mac (downloaded with home-brew and later with .dmg from their website).

I tried tinkering with Godot’s “drivers” code section and the Godot.app’s files, but it didn’t help at all.

Did I do something wrong ? Or is it that Godot 4.0 just isn’t properly set up to work with Mac yet ?

:bust_in_silhouette: Reply From: kidscancode

Godot 4.0 is in development, and is still very unstable. It is not ready to be used yet.

You should stick to 3.2, which you can download already compiled for Mac OS. If for some reason, you do need to compile from source, make sure you’re using the 3.2 branch.