Godot 4 does not open while the 3.5 version opens?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Itsu0

I tried opening Godot 4 but it does not open any window nor I get any errors. The console window does not print anything when I open it. Tried updating my drivers, reinstalling windows but none work.
Godot 3.5 opens normally.
I’m running windows 11.

I’d guess the problem is graphics driver related. What happens if you start it from a CMD terminal, and add the --verbose command line arg?

jgodfrey | 2023-03-02 18:54

Further, if the problem IS related to your hardware not supporting the default vulkan render mechanism, you can try to add the following to your command line to force the use of the opengl3 driver:

--rendering-driver opengl3

jgodfrey | 2023-03-02 19:29

It gives me this error saying the command is not recognized? Am I doing something wrong?
‘–verbose’ is not recognized as an internal or external command,
operable program or batch file.

Itsu0 | 2023-03-02 19:31

I have a GTX 1070ti with updated drivers, currently running Windows 11.
Could it be some issue with the OS or am I missing some driver?

Itsu0 | 2023-03-02 19:32

Sorry, I should have been more explicit. For that first suggestion you want something like:

C:\path\to\your\godot4.exe --verbose

That will likely give you information about what’s causing the problem.

And, if the problem is related to the Vulkan renderer, that second suggestion above might work around it. That’d look something like:

C:\path\to\your\godot4.exe --rendering-driver opengl3

Though, you’ll obviously need to point to the specific Godot 4 executable you’re trying to run.

jgodfrey | 2023-03-02 19:39

I navigated to the correct file and ran the --verbose command, it did not output anything, it just went to the next line, the same with the --rendering-driver opengl3 command. Sorry, I’m actually not that familiar with the console, should it output something?

Itsu0 | 2023-03-02 19:52

The weird part for me is that the 3.5 version works fine, and when I open the console it outputs:

Godot Engine v3.5.1.stable.official.6fed1ffa3 - https://godotengine.org
OpenGL ES 3.0 Renderer: NVIDIA GeForce GTX 1070 Ti/PCIe/SSE2
Async. shader compilation: OFF

But when I open the Godot 4 console it’s completely empty.

Itsu0 | 2023-03-02 20:01

Hmmm… That’s odd. For example, here’s what I see when starting Godot 4 stable with the --verbose cmdline arg:

Command line:

C:\Dev\godot-binaries\Godot_v4.0-stable_win64.exe --verbose


Godot Engine v4.0.stable.official.92bee43ad - https://godotengine.org
TextServer: Added interface "Dummy"
TextServer: Added interface "ICU / HarfBuzz / Graphite (Built-in)"
Text-to-Speech: SAPI initialized.
Using "winink" pen tablet driver...
OpenGL API 3.3.0 NVIDIA 528.49 - Compatibility - Using Device: NVIDIA Corporation - NVIDIA GeForce RTX 3060 Laptop GPU
WASAPI: Activated output_device using IAudioClient3 interface
WASAPI: wFormatTag = 65534
WASAPI: nChannels = 2
WASAPI: nSamplesPerSec = 48000
WASAPI: nAvgBytesPerSec = 384000
WASAPI: nBlockAlign = 8
WASAPI: wBitsPerSample = 32
WASAPI: cbSize = 22
WASAPI: mix_rate = 48000
WASAPI: fundamental_period_frames = 480
WASAPI: min_period_frames = 480
WASAPI: max_period_frames = 480
WASAPI: selected a period frame size of 480
WASAPI: detected 2 channels
WASAPI: audio buffer frames: 480 calculated latency: 10ms

TextServer: Primary interface set to: "ICU / HarfBuzz / Graphite (Built-in)".
CORE API HASH: 132356682
EDITOR API HASH: 2535829357
EditorSettings: Load OK!
Project is missing: C:/Dev/Godot/project.godot
Loaded builtin certs
EditorSettings: Save OK!

jgodfrey | 2023-03-02 20:24

I just tried running the --verbose command in the Godot 3.5 version and it works fine! It even outputs some of the same values as your output. The Godot 4 simply does not open nor does it give any output. I’m so confused! Can it be some issue with the 4.0 release? Or maybe some compatibility issues with Windows 11?
Here’s the output for the Godot 3.5 --verbose:

C:\Dev\Godot 3.5>
Godot Engine v3.5.1.stable.official.6fed1ffa3 - https://godotengine.org
Using GLES3 video driver
OpenGL ES 3.0 Renderer: NVIDIA GeForce GTX 1070 Ti/PCIe/SSE2
Async. shader compilation: OFF
OpenGL ES 2D Batching: ON
Batching Options:
        max_join_item_commands 16
        colored_vertex_format_threshold 0.25
        batch_buffer_size 16384
        light_scissor_area_threshold 1
        item_reordering_lookahead 4
        light_max_join_items 32
        single_rect_fallback False
        debug_flash False
        diagnose_frame False
WASAPI: wFormatTag = 65534
WASAPI: nChannels = 8
WASAPI: nSamplesPerSec = 48000
WASAPI: nAvgBytesPerSec = 1536000
WASAPI: nBlockAlign = 32
WASAPI: wBitsPerSample = 32
WASAPI: cbSize = 22
WASAPI: detected 8 channels
WASAPI: audio buffer frames: 1962 calculated latency: 44ms

CORE API HASH: 6609155589855387091
EDITOR API HASH: 17280644357449250417
Loading resource: C:/Users/theoy/AppData/Roaming/Godot/editor_settings-3.tres
EditorSettings: Load OK!
EditorSettings: Save OK!
Loaded builtin certs

Itsu0 | 2023-03-02 20:34

My posted results are from Win11 also, so no issue there. I wonder if you might have a virus scanner (or similar) that’s stopping the application from running? Or, perhaps your exe is corrupted (though, seems doubtful). Maybe download it again and try a new copy?

jgodfrey | 2023-03-02 20:43

Thank you for the continuous help! I’m still currently trying to fix the issue. I’ve found out that another person had the same issue as me. This video shows the exact problem I have: Video.
Tried turning off Windows Defender but it did not work, don’t think that a third party program is blocking anything. I think it’s some problem with OpenGL? Someone in the comments said that “He had to copy some opengl file from 1 of his projects to new godot beta folder.” I wonder if this could solve my problem but I’m not sure how to access this file.

Itsu0 | 2023-03-03 01:43