Godot 4 - When setting up Visual Studio Code on MacOS I cannot start Godot from the launch.json script.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Dalo

Godot 4 beta 8, Visual Studio Code 1.74.0 macOS Big Sur

I would like to edit c# files in VSC. In the VSC launch.json script I have put the Godot path to:
“program”: “/Applications/Godot.app”,

When I try to launch I get “launch: program’/Applications/…” does not exist"
I have tried Godot, Godot.app, Godot/Contents/MacOS/godot without any luck.
I have also tried Godot 3 versions.

I am doing something fundamentally wrong, could anyone offer any thoughts?
Many thanks

Consider adding “Godot 4” to the title. You may more easily catch the eyes of a contributor that can look at the source code and see if it’s a bug.

timothybrentwood | 2022-12-14 03:46

:bust_in_silhouette: Reply From: Dalo

I have found my mistake. I used ps | grep in terminal to find the path to the running Godot process.

The program line in my case in launch.json. is;
“program”: “/Applications/Godot_mono_beta_8.app/Contents/MacOS/godot”,

I have read somewhere that Godot 4 needs .Net 6.0, not 7.0. I am not sure if that is the case, but have changed it.

Everything now works beautifully.