Godot collision polygon not showing up

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By WilliamD47

I have a wall with a static body2d as the main node. There is a CollisionPolygone2D also and this is making up a cave like wall. When I run the preview thing in the engine everything shows up and it all works but when I make it an .exe file for my computer the walls dont show up. The main character does though. Please can you help as I cannot go further with my game without being able to see the walls.

:bust_in_silhouette: Reply From: Zylann

CollisionPolygon2D only shows up in the editor and sometimes in the game preview if debug collision shapes are enabled. However, as the name says, this is only for debug purposes, so it will never show in an exported game.

If you want your cave to show up, you need to have a proper visual node, such as Polygon2D.

I have fixed it now as I had tried to use a collision polygon as a paint tool.

WilliamD47 | 2020-02-18 15:30