Godot Crash When Opening a Project

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By PleaseTellMeAnAnswer

Hello,
I am on Fedora 37, I have installed Godot 4 with flatpak and I have not installed any graphic driver.

Every time I open a project or create a new one the engine crashes. I tried using the portable version but it still doesn’t work.

Here’s what I get from neofetch in a terminal :

OS: Fedora Linux 37 (Workstation Edition) 
Host: NM853AA-ABF p6025fr 
Kernel: 6.0.7-301.fc37.x86_64 
Uptime: 4 hours, 15 mins 
Packages: 1948 (rpm), 44 (flatpak) 
Shell: bash 5.2.15 
Resolution: 1920x1080 
DE: GNOME 43.3 
WM: Mutter 
WM Theme: Adwaita 
cTheme: adw-gtk3-dark [GTK2/3] 
Icons: Adwaita [GTK2/3] 
Terminal: kgx 
CPU: AMD Phenom 9650 (4) @ 2.300GHz 
GPU: NVIDIA GeForce GT 120 
Memory: 4074MiB / 5927MiB 
                                                                 
:bust_in_silhouette: Reply From: jgodfrey

According to this, that GPU doesn’t support the Vulkan rendering API. It does, however, support OpenGL3. You can force Godot 4 to use OpenGL3 instead of Vulkan by starting it from a command terminal and supplying an appropriate command line arg. Specifically, something like this:

C:\path\to\your\godot4.exe --rendering-driver opengl3

I tried to edit the .desktop file of Godot (containing the app shortcut settings on Linux) to always set the renderer to OpenGL3 but it doesn’t seem to work.

For now I am probably going to use Godot 3.

PleaseTellMeAnAnswer | 2023-04-08 11:01

Ah, apologies for the Windows example. You did say you were using Linux…

When you say it doesn’t seem to work, are you having an issue with shortcut file or with Godot itself now? What happens if you just attempt to start Godot from a terminal window and supply the command line arg there?

jgodfrey | 2023-04-08 13:44