Godot crashes when importing assets

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Fupicat

I’m teaching a friend how to use Godot, so we set up a GitHub repo for our game. We managed to work together with no hassle a few days ago, but now the project crashes every time I try to open the project, only on my machine. He can pull any changes I make and still open the project.

It crashes specifically at the (Re)Importing assets phase. The bar gets through 80-83% and then the program stops responding forever.

Here’s the repo: https://github.com/Fupicat/jogo-foda/ Se vc fala português desculpa o nome viu

Since the problem seemed to be with importing, I tried:

  • Deleting the .import folder
  • Deleting every .import file
  • Adding it to .gitignore and then deleting it from the repo
  • Redownloading Godot
  • Restarting my PC
  • Opening a zip file straight from my friend’s machine without cloning the repo and without the .git folder

Nothing worked, I’m just clueless right now.

:bust_in_silhouette: Reply From: Amateur.game.dev.

It may be because the file is too large. This happens to me ALL the time when I tidy my filesystem. All you have to do is start the editor and DO NOT touch the mouse or the keyboard until it says that the import is done, because this would cause the engine to be overworked into doing too many things in one time, thus it would crash. If that doesn’t work then I don’t know what else to tell you.

No, I know importing takes a while but this was literally infinite. I’ve already got an answer though, apparently it was a bug and downloading Godot 3.2.4rc5 allowed me to open it. Reddit - Dive into anything

Fupicat | 2021-03-15 23:15

:bust_in_silhouette: Reply From: Fupicat

Update: read this thread for solution: Reddit - Dive into anything

:bust_in_silhouette: Reply From: omggomb

FYI: I traced it down to be the font you use. What I did was delete one resource after another unitl the project opened. I couldn’t find out which fix adresses this in 3.2.4 though. Weidly enough other true type fonts like consolas work fine.

Damn, that’s bizarre. Thanks for doing all this work, I never thought about the font.

Fupicat | 2021-03-17 11:15