Godot Debug starts and stops immediately

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By darius.pranskus


This is my first attempt to create something in Godot. But I have some experience with Unity and Game maker. I started building a project, and it comes together quite nicely.

But I am facing a problem, when I start debugging, no window is opened, no errors displayed, but in the output window I see

— Debugging process started —
— Debugging process stopped —

That’s it. I also created an empty project with empty scene, all the same. I was expecting that it at least shows an empty window.

Tried 3.2.1 and 3.2.2.b1, all the same.

I am on Mac Catalina 10.15.4

Not sure what might be a problem

Please, experts advise

There’s probably not enough info to answer this. Is there any info in the console/terminal?

andersmmg | 2020-04-21 17:37

andersmmg has a point there. Try opening up the executable from the command line. It may spit out some error message when you try to debug your project.

Ertain | 2020-04-26 07:00

I’m having the exact same problem with Godot 3.3.2.

Mushin | 2021-08-01 17:37

Happened this same problem with Godot 3.3.3

Idk what may the problem is, tried to run it on cmd but didnt show any error

Rod77 | 2021-09-30 15:55

:bust_in_silhouette: Reply From: Azevedo

Same here with mono 3.2.2

:bust_in_silhouette: Reply From: Chidebe Nosiri

For me, using it on WIndows 10 might be because the project is hefty
I don’t know about your Mac Catalina, but mine was because of the following:

Sprite player = (Sprite)GetNode("res://ProjectFolder/Character.tscn");

	if (player.Position <= DistanceToPlayer)
		DrawLine(this.Position, player.Position, LineColor, 1, false);

So I don’t know if that is hefty for my PC (an AMD Radeon R4 Graphics card and others),

Hope this helps!

:bust_in_silhouette: Reply From: SkyCrusherer

In my case I face with this porblem when I tried to inherit class from custom abstract class. Check inheritings…

:bust_in_silhouette: Reply From: Wavey

It happened to me just now, I fixed it by renaming my project. It happened because I had special characters in the project title. Just edit the project name, remove/replace special characters with letters:
Project settings → General → Application → Config → Name

:bust_in_silhouette: Reply From: Leon12


For me it was about fixing some broken dependencies in the theme that I was using, specifically it was about some missing Fonts. I’m using Godot 4.0.3 stable.

Hope it helps :slight_smile: