Godot doesn't start due to OpenGL version

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By V1R23

Hello everyone! I have a problem with the Engine and I can’t seem to find any information about it.


I recently downloaded Godot Engine from here (x86_64bit version)
When trying to open the Engine, a warning appears: “Your video card driver does not support any of the supported OpenGL versions. Please update your drivers or if you have a very old integrated GPU, upgrade it.”. This prevents me to access the project selection and the editor.

This warning seems a bit odd to me, since I have a new(ish) laptop, and I can’t find any useful information on the internet. I’ll leave some detailed information about the sistem below.


How do I solve this issue? The first time I opened it, it worked fine, but from the second time onwards I can’t manage to use the Engine whatsoever.

System Information:

  • CPU: Intel 11th gen processor;
  • Integrated GPU: Intel Iris Xe Graphics (Driver version, release date 24-Jun-2021);
  • Dedicated GPU: Nvdia GeForce MX350 (Driver version, GeForce 516.94, release date 21-Jul-2022);
  • I have no way to estabilish if I have OpenGL and which version is on my machine;
  • Windows version: Windows 11 Home version 21H2, OS Build 22000.856.

From what I can guess these are not old drivers or hardware, so I don’t really know what to do to solve this issue.

Thanks in advance :slight_smile:

:bust_in_silhouette: Reply From: jgodfrey

I’d guess the issue really is with the video driver. It’s likely either out of date or somehow misinstalled. If updating / reinstalling the driver doesn’t help you could try to start the editor from the command line using:

godot.exe --editor --video-driver GLES2

Additionally, you could try this to see if anything interesting is shown in the CMD window.

godot.exe --editor --debug

jgodfrey | 2022-08-29 00:16

Thank you for the answer! Unfortunately, using the command you mentioned doesn’t solve the problem, it gives me the same warning about the video drivers (also the debug doesn’t show anything useful)

I really don’t know what to do: the laptop is almost brand new and the drivers are up to date in relation to the OEM reccomendations

Do you have another suggestion on what I can try?

V1R23 | 2022-08-29 07:18

You can validate your OpenGL support via the OpenGL Extensions Viewer.

The actual download link on that page says “Download For Windows” (there are other ad-based download links on the page, which I dislike).

  • I wonder if your “NVIDIA Control Panel” shows anything interesting?

  • Maybe you can force Godot to run on a specific GPU via the NVIDIA Control Panel?

jgodfrey | 2022-08-29 14:54

I can’t seem to find anything interesting on the Nvdia Control Panel (it seems I have very limited options there), but in the tool you kindly suggested I can see that the Integrated Graphics have version 4.6 of OpenGL

V1R23 | 2022-08-29 15:53

In the NVIDIA Control Panel, which GPU is assigned to Godot for “OpenGL rendering”?

It seems that either of your GPU’s should support the necessary OpenGL for Godot. It still feels like something must be broken in your GPU drivers.

Have you tried to uninstall and reinstall them?

Really, just grasping at straws here…

jgodfrey | 2022-08-29 16:57

Try installing the latest driver version provided by NVIDIA/Intel (not your laptop OEM, not Windows Update). Drivers provided by laptop OEMs and Windows Update are often outdated and feature weird quirks.

Calinou | 2022-08-29 16:59

I’ll try everything you suggested and I’ll let you know, thank you very much for all your suggestions!!

In the meantime, between yesterday and today, something happened:

  1. After a restart, the Engine seemed to work! I just opened an empty project and put it in the background just to see if it crashed, but it didn’t happen!
  2. This morning I turned on the laptop and the Engine was still working, I just created a Scene with a label and closed it;
  3. Just a few minutes ago I tried opening the Engine again and it gave me the usual error. (Between step 2 and 3 I didn’t do any restarts or shutdowns)

Right now I’ll try to install updated drivers directly from the manufacturers. I know for sure that the Nvidia ones are updated because I usually update through GeForce, but I’ll try anyway

Thank you all for your help!

V1R23 | 2022-08-30 08:17

So, after one day, I updated the Intel Driver (the only one out of date) and the Engine started right after the installation!
But this morning, after booting up the pc, the same error occurred.
I restarted the pc and the error disappeared.

It doesn’t seem like there’s a driver issue, because even last time the Engine worked after a restart

Guess I’ll do it everytime I see the error. It’s not the best for usability but, hey, it works

Thank you for all your help! :slight_smile:

V1R23 | 2022-08-31 07:57