GoDot IDE Running VERY Slowly - I Know What The Issue Is

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By JHAustin1969

Hello All,

I am new to GoDot, as of today, so I haven’t worked with it much yet.

The issue is that the Engine/IDE runs extremely slowly. The Projects work fine, but the engine can take up to 20 seconds for every action, including just starting the program.

Although I cannot fix the problem, I know what is causing it, so I am reporting it here, because I am not sure where else to put it.

The cause of the slow down is because I have 2 monitors. I know this, because, if I keep the focus on just the monitor GoDot is using, everything runs very slowly. If I choose an action on GoDot and then switch focus to a program on the other monitor and then back to GoDot, it works right away.

So apparently, there is an issue when using dual monitors, that causes the IDE/Engine to wait for something to happen, before acknowledging any button presses, or even text entry into a field.

I searched through the questions and saw that others had a slow down issue as well, that were not solved, as far as I know, so I wonder if maybe they also had Dual Monitors.

Either way, this is something that probably needs to be addressed.

Thank you,
Joe Austin

What operating system? I have been using Godot regularly for years with 2-3 monitors under MacOS and Linux without any problems. The issue may be OS-related or video card/driver related.

kidscancode | 2019-07-26 19:25

What OS? What graphics card? I run Godot on Windows on a laptop with two screens attached to it (so triple screens setup) and I don’t have this issue.

BraindeadBZH | 2019-07-26 19:44

OS and PC Specs:
Window 10 - All Updates Installed
Intel Core i7 @ 3.6GHz
16 GB Ram
64-bit OS

Graphics Card:
Intel HD Graphics 630 - Latest Drivers Installed

I suppose it could be related to the Graphics Card, since it is built into the motherboard, but I do run quite a few other programs that are graphic intensive and they seems to work fine. Game engines like GDevelop, Construct2, GameGuru, as well as other programming languages and their IDEs.

This is the only program that has displayed this type of behavior.

Thank you,

JHAustin1969 | 2019-07-26 19:57

:bust_in_silhouette: Reply From: loopernow

I believe what you’re seeing is that the UI refreshes whenever you focus on another application and then come back. It’s not that the other application is on another monitor, it’s just that it’s another application.

I was having the same issue–and I found a fix in this thread: Editor doesn't draw properly (one frame lag) on systems with Intel drivers (driver vendor bug) · Issue #23069 · godotengine/godot · GitHub (“Editor doesn’t draw properly (one frame lag) on systems with Intel drivers (driver vendor bug) #23069”)

The fix that worked for me was:
"Mastermori commented on Jan 11, 2020 •
“I had this issue as well and what (confusingly) fixed it for me was activating the update spinner. This can be done in Editor → Editor Settings → Interface → Editor → Show Update Spinner. I am running windows 10 and I had this issue on all recent Godot versions (stable and beta). I tried this fix on beta 3.2beta5. It probably works now because it updates the spinner, whenever I press anything and thereby advances another frame, making my inputs work right away.”

I hope this helps you.