Godot is messing up with .csv files

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By snk

I was using csv files for data storage, it has worked just fine for several hours and then Godot suddenly started to mess with the files for no apparent reasons. When I do a print() to se what Godot is reading from the files I got things like @@7 @@15 @@19

I read somewhere that Godot were forcing all the csv files it gets to translation files, but why did it let me working just fine for several hours with my .csv without touching it ? (I didn’t used the import feature to add my files, I just dropped them in the project folder".

Trying to add new files into the folder now instant triggers Godot to mess with it… changing from .csv to .txt doen’t work either.

If someone knows how I could stop godot from touching the csv files, thanks.

So the engine is changing the contents of your CSV files? And you’ve opened them up with a text editor to verify that it is changing the data in an unintended way?

Ertain | 2018-07-08 20:26

“@@7” looks like an auto generated node name. Check your write functions, especially where you serialize and write the nodes into this file.

David Krause | 2018-07-09 10:26

You are right. I have no functions that write into these files, but I was procedurally generating nodes and they were getting their characteristics (including their names) from them.
After a deeper inspection I found that I had a misplaced print funtion that reflected me the generated nodes with their stock names.

I mingled these values with the ones inside the “corrupted csv files” because they where filled with tons of @@^@^^^^^@@^@@@@@@@@^@@^1@@^@@11255 (the same kind of gibberish you get when you try to read in utf-8 a file generated by a precompiler actually, which was very weird).

snk | 2018-07-09 18:04

:bust_in_silhouette: Reply From: snk

I re-opened the project today and the problem just seems to have disapperead by itself. I tried a few things to reproduce the bug to help me identify the cause but I didn’t manage to have it again.

If only I could solve all software problems like this… :rolleyes: