Godot is not opening

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Surya Prakash

I have downloaded godot v3.1.1. I have first tried to open it but it doesn’t. It just shows a white screen.

Could you give us more details about your situation? What OS are you using?

Ertain | 2019-11-03 19:05

Probably an issue with your graphics card driver and OPENGL3.
Which graphics card / chipset do you use?
Is your driver version up to date?
If you’re using windows then it might be helpful to install the latest manufacturer driver (if available) instead of the standard windows driver.

Try to run <godot executable name> --video-driver GLES2

(Replace the first part with the actual name of the godot executable)

wombatstampede | 2019-11-04 07:21

I am running windows 7 on Intel i5-3210M.
GPU-AMD Radeon HD 7670M.
OpenGL 3.3

Surya Prakash | 2019-11-04 08:05

Hiii wombatstampede
First of all Thank You, cause godot is opening by running it as you said but it shows an error message like
ERROR: initialize: Directional shadow framebuffer status invalid.

But wait, every single time I want to open in this way or what? Please let me know what to do

Surya Prakash | 2019-11-04 08:21

:bust_in_silhouette: Reply From: wombatstampede

Opening Godot in OpenGL2 is the last resort when there are incompatibilities with your OpenGL3 device/drivers.

#1 If you want to pass command line parameters every time on start then you can use a batch file. Create a file with the extension .bat or .cmd with a text editor and put the command line inside. You can create a link to such a batch file to your desktop / startmenu.
#2 Alternatively, you can just add the parameters when editing the link settings. (I think)

But you didn’t answer to the question if your graphics card driver is up to date:

Here are the AMD downloads for your graphics chipset:
See also:

If your notebook manufacturer (i guess by the “M” that you use a notebook) offers own graphics drivers then first check if their site offers a newer driver because manufacturer specific drivers might contain extensions specific to your notebook.

I have installed the latest drivers and the problem is solved.
Thank you very much.

Surya Prakash | 2019-11-04 14:17