godot is slow to open or run projects

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By MainWolf55

Hello everyone , been having some issues with Godot in that some times the program is quick to open and functions normally and others (most of the time)is slow , for example , takes like 40 seconds to run a blank game project , this is obsessing for a beginner like me who wants to learn the engine. thanks:)

I have never had this problem before.

Merlin1846 | 2020-03-19 23:20

:bust_in_silhouette: Reply From: payload505

the problem shouldn’t be from godot itself maybe it’s your computer

:bust_in_silhouette: Reply From: wombatstampede

While there are multiple possibilities (i.e. older graphics drivers) there is a known issue:

This seems to be related to USB input devices. You can try it out by removing the USB devices (each on its own) before starting godot and then comparing the startup time.

As an example: There was somebody with a Corsair Keyboard which solved the problem by installing a firmware-update for the keyboard.

Thank you so much Wombats, my keyboard is from corsair ,didn’t bother to install the drivers until now , but after that , Godot is running normally and fast , thank you once again !!

MainWolf55 | 2020-03-18 03:41

Thanks for this answer, I also have a corsair KB but firmware was up to date. I was able to fix my problem by reducing the polling speed down to 125 from 1000 :slight_smile:

Avodroc | 2020-05-05 22:13

:bust_in_silhouette: Reply From: MmTtDeveloper

This is a known problem in Godot since 3.0. To fix it, you can try to update your graphics drivers, though if that doesn’t work, you could open Godot and navigate to Editor > Editor Settings > Interface > Editor and turn on Update Continuously.